WL32 crashed after prefix update

You may post here if you are having problems with Winlog32 that others may be able to help you with. You may also report bugs so that the author may act upon them.
Post Reply
DL4KG
Bit of a boffin
Posts: 67
Joined: Wed Jan 09, 2002 5:09 am
Location: Stuttgart, Germany
Contact:

WL32 crashed after prefix update

Post by DL4KG »

After updating the prefix database WL32 (7.3.49) came up with a message: bad or missing prefix database - replacing bad file
After clicking on OK, next message comes up saying ERROR :0: / 5
I downloaded the prefix file from the homepage but nothing changes. When checking the prefix database information it says:
prefix database version 4
last updated 26.09.2023
master entries ####
calld´signb exceptions 28462
total number of entries ####

WL32 layout is totally greyed out and looks like I should start from scatch.

Any idea what I can do to make WL32 run again?Image
Attachments
WL32_message 2.PNG
WL32_message 2.PNG (4.46 KiB) Viewed 35631 times
WL32_message 1.PNG
WL32_message 1.PNG (9.67 KiB) Viewed 35631 times
73 de Gerald - DL4KG
DL4KG
Bit of a boffin
Posts: 67
Joined: Wed Jan 09, 2002 5:09 am
Location: Stuttgart, Germany
Contact:

Re: WL32 crashed after prefix update

Post by DL4KG »

Finally I installed WL32 from scratch and reinstalled the ini-file and the log file. Everything is working fine now. So problem solved.

Being a user for about 25 years I still love WL32. Big thanks to Colin for that nice program and the support over all the years.
73 de Gerald - DL4KG
User avatar
SV1GRB
Keen user
Posts: 44
Joined: Sat Nov 22, 2014 9:34 pm
Contact:

Re: WL32 crashed after prefix update

Post by SV1GRB »

It is great that you found a solution.
I have seen similar behavior after uninstalling other applications that use some shared libraries or components from the system.
For example, the programming software of Alinco or Anytone DMR transceivers use some shared components and when uninstalling them, they are removing these needed files.
With the re-installation of Winlog32, you simply putted these dependencies back in their place.

73
Haris
SV1GRB
G0CUZ
Site Admin
Posts: 463
Joined: Wed Jan 02, 2002 7:12 am

Re: WL32 crashed after prefix update

Post by G0CUZ »

Sorry I came late on scene, but anyhow you found a practical solution, as Haris said, there probably was a corrupt or missing DLL, or prefix database itself could have corrupted.
Maybe info for others faced with similar problem, I will add that a full re-install over the top of the existing installation would resolve such issues, if the problem was actually with the Prefix database, then the file 'Prefix.mdb' in winlog32/Data folder should be deleted before the re-install to be sure it will be replaced with a good copy of the prefix file.

73 Gerald & Haris

Colin, G0CUZ
Post Reply