Database problem

You may post here if you are having problems with Winlog32 that others may be able to help you with. You may also report bugs so that the author may act upon them.
Post Reply
onl5923
New user
Posts: 0
Joined: Mon Jan 07, 2002 4:53 pm

Database problem

Post by onl5923 » Sat Oct 04, 2008 6:13 am

Hi all,

For some reason I keep receiving an error messagea when starting up WL32.

I have 2 logs in my WL32. One works perfectly the other one gets the message: "Can not update database 3343, DXCC.MDB

What also happens and only with this log is that the background in the cluster is black instead of the usual green colour and it does not highlight any new ones in red anymore anymore. So this only happens in this log and not in the other log I use in WL32.

Any ideas?

Thank you and 73, de Peter ON3WAB/ONL5923



Edited by - ONL5923 on 07/10/2008 4:00:34 PM

onl5923
New user
Posts: 0
Joined: Mon Jan 07, 2002 4:53 pm

Database problem

Post by onl5923 » Sat Oct 04, 2008 6:13 am

I also experienced the follwing today. When entered a callsign and I press "enter" nothing happens. Sometimes the progamme even shuts down by itself.

When I go to the date window manually then I can continue logging the rest of the details.

Maybe this is all related to the problem mentioned before?

73,
Peter

G0CUZ
Site Admin
Posts: 324
Joined: Wed Jan 02, 2002 7:12 am

Database problem

Post by G0CUZ » Sat Oct 04, 2008 6:13 am

Hi Peter

The problem is almost surely the DXCC (Prefix) database has not been updated to version 4 for the other log.

Load the log that gives the problem, then menu/File/Maintenance/File maintenance - UPDATE DXCC.

This need to be done for each Individual Log's DXCC database.

73 Colin G0CUZ
Winlog32 Author

onl5923
New user
Posts: 0
Joined: Mon Jan 07, 2002 4:53 pm

Database problem

Post by onl5923 » Sat Oct 04, 2008 6:13 am

Hello Colin,

Hope you are well.

I have tried the file maintenance and I get following message:

"runtime error "91" object variable or with block variable not set.

When I press "ok" (only option), then the programme shuts down completly.

Peter




Edited by - ONL5923 on 12/10/2008 8:41:21 PM

G0CUZ
Site Admin
Posts: 324
Joined: Wed Jan 02, 2002 7:12 am

Database problem

Post by G0CUZ » Sat Oct 04, 2008 6:13 am

Hi Peter

Could be the DXCC database is corrupted or even missing.

If it is missing - and this is indicated by DXCC being 'greyed out' in the Database menu - You can replace the file using the 'Create Ancillary Set' in the Menu/File/Maintenance window, this will only replace any 'missing' file
Remember for any of these chjecks you must have the appropriate Log LOADED into Winlog32

If the file is present and you can not open it in the Database menu - then try a 'reapair' using the utility in the Maintenance window - this often (but not always) works.

If all else fails, open Windows File manager (My Computer) manually delete the corrupt file 'DXCC.MDB' and follow the first procedure. IT IS IMPORTANT THAT YOU DELETE THE CORRECT FILE!! as there will be more than one DXCC.MDB file in your Winlog32 installation, if you don't know how to choose the correct one I will tell you if you give me the name of your BAD Log Database - that's the name in the Winlog32 lower informnation bar.
- something like C:\Program FilesWinlog32\LOGS\*MYLOG*.LOG




73 Colin G0CUZ
Winlog32 Author

onl5923
New user
Posts: 0
Joined: Mon Jan 07, 2002 4:53 pm

Database problem

Post by onl5923 » Sat Oct 04, 2008 6:13 am

Hi Colin,

I tried the first option and it works fine again now

many thanks,

73, Peter, ONL5923/ON3WAB

Post Reply