Log entries get warning of "Error in Data"

You may post here if you are having problems with Winlog32 that others may be able to help you with. You may also report bugs so that the author may act upon them.
KI4WCQ
Keen user
Posts: 15
Joined: Tue May 05, 2015 12:04 am
Location: Elizabethtown, KY

Log entries get warning of "Error in Data"

Post by KI4WCQ » Tue May 05, 2015 4:17 pm

When I finish a log entry it give me "Error in Data" warning just above the callsign entry. Likewise, when I try to update the QSL in field and the auto upload to Clublog, I get the same entry and Clublog no longer updates.

This has been a problem in the last three weeks. Prior to that, Winlog32 worked great on posting new contacts to Clublog and also updating QSLs received.

I am using v 6.1.7.

Operating system is XP.

The setting in Real Time upload for Clublog is correct.

Any idea on how to fix this "Error in Data" that shows up now on each new entry or when attemping to post received QSLs to earlier log entries?

Thanks and 73,
Johnny

G1DYC
New user
Posts: 6
Joined: Mon Apr 27, 2015 2:10 pm
Location: Droitwich

Re: Log entries get warning of "Error in Data"

Post by G1DYC » Tue May 05, 2015 10:00 pm

Johnny,

Have a look at "Clublog real time upload" by IT9PQJ, it sounds similar to your problem and has been resolved by Colin by issuing an update to WinLog. It explains a possible issue.

73,

Dave G1DYC

KI4WCQ
Keen user
Posts: 15
Joined: Tue May 05, 2015 12:04 am
Location: Elizabethtown, KY

Re: Log entries get warning of "Error in Data"

Post by KI4WCQ » Tue May 05, 2015 10:37 pm

I looked at that post and it isn't the problem I'm having. It does it on all entries, not just WARC bands.

I have made several "test" entries with a friend's call sign on various bands and get the "error in data" on every entry.

DL4KG
Complete Boffin
Posts: 257
Joined: Wed Jan 09, 2002 5:09 am
Location: Stuttgart, Germany
Contact:

Re: Log entries get warning of "Error in Data"

Post by DL4KG » Wed May 06, 2015 5:05 pm

At first I recommend to update to the latest version of WL32. You are using 6.1.7. Meanwhile Colin developed 6.2.5. I had a similar problem with the interface to FLDIGI and that was based on a change in the FLDIGI protocol. Maybe there is a similar issue with Clublog.
73 de Gerald - DL4KG

KI4WCQ
Keen user
Posts: 15
Joined: Tue May 05, 2015 12:04 am
Location: Elizabethtown, KY

Re: Log entries get warning of "Error in Data"

Post by KI4WCQ » Wed May 06, 2015 5:25 pm

I just installed the Beta version as it was the only one later than what I had. I still get the "error in data" on all entries as before when I try to auto upload to Clublog.

Although I don't use auto upload for eQSL, I tested that function and it works. Something is wrong in the Clublog and Winlog32 interface.

I need help!

G0CUZ
Site Admin
Posts: 1630
Joined: Wed Jan 02, 2002 7:12 am

Re: Log entries get warning of "Error in Data"

Post by G0CUZ » Wed May 06, 2015 8:22 pm

I just uploaded a test QSO to Clublog, all went as expected so the API is working.

What version of Winlog32 are you using? as previously stated - you will get the 'error' report because of recent changes in the Clublog API in some circumstances, this has been overcome in latest Winlog32 version.

If the problem persists, check your QSO data for errors, the upload needs minimum valid: Callsign; Date; time; frequency band; mode.

If still no joy, send me a screen shot of the reported error.

73 Colin
G0CUZ

KI4WCQ
Keen user
Posts: 15
Joined: Tue May 05, 2015 12:04 am
Location: Elizabethtown, KY

Re: Log entries get warning of "Error in Data"

Post by KI4WCQ » Wed May 06, 2015 10:19 pm

I am using v6.2.6 today. Yesterday I tried v6.1.7...no change on this end.

I sent you a screenshot yesterday, about midnight your local time, in email and also some follow up emails today as I tried to work through the problem.

The screenshot is when I was on v6.1.7, but it appears the same way in today's v6.2.6. I will resend it with my call in the subject line.

73,
Johnny KI4WCQ

KI4WCQ
Keen user
Posts: 15
Joined: Tue May 05, 2015 12:04 am
Location: Elizabethtown, KY

Re: Log entries get warning of "Error in Data"

Post by KI4WCQ » Thu May 07, 2015 9:16 pm

Still no luck on the auto upload to Clublog, but here is some more information that I am sharing in the hope someone has a solution.

After I use the "end" button following making a new log entry and responding "yes" to the"do you want to upload to Clublog" query is when I get the "error in data" warning, and no upload to Clublog occurs.

If instead I select "no" and then go to File-Export ADIF-Clublog, it will export the entry and will then upload it to Clublog if I select the middle "upload" button on the export pane. This is rather cumbersome method to update Clublog and risks the danger of clearing Clublog if one should happen to answer the ensuing questions following the use of the upload button as Yes/Yes instead of Yes/No.

It appears that the upload will work somewhat in a semi-auto fashion, but certainly not fully automatically as it used to.

Johnny KI4WCQ

G0CUZ
Site Admin
Posts: 1630
Joined: Wed Jan 02, 2002 7:12 am

Re: Log entries get warning of "Error in Data"

Post by G0CUZ » Fri May 08, 2015 9:00 pm

Hi Jonny

Sorry, but no emails have been received from you! so it is not because I am ignoring them, hi.

Can you resend and please check the address is OK, also are you including attachments? please zip any attachments as they can get rejected by mail server before it reaches me, I DON'T use spam filters here.

I still don't know what the problem is, no one else has reported any problems with latest version in this respect, so I will have to look at a screen shot of your log at time of sending data.

73 Colin
G0CUZ

KI4WCQ
Keen user
Posts: 15
Joined: Tue May 05, 2015 12:04 am
Location: Elizabethtown, KY

Re: Log entries get warning of "Error in Data"

Post by KI4WCQ » Sat May 09, 2015 1:03 am

Colin,

I am using this email address: winlog@blueyonder.co.uk

Is this correct? I have sent five to that address.

73,
Johnny KI4WCQ

Post Reply